Forum » General » Support Forum - Software » Windows Installation of Beta+2C

Share this Topic

Windows Installation of Beta+2C

  • After downloading the "78+Community+Cataloger+-+Beta+2C.exe", I expected it to run an installer program. Instead I get the security warning as if it were going to run an installer program and then after pressing "Run", the Cataloger program itself runs. It works fine, but it doesn't actually "install". The directories of "78rpmCat", etc. show up in the "User" areas. Is it suppose to "install"? When I use the "Cataloger" as is, I get the security warning every time. This was the same when using Windows XP or a Windows 7 operating system.
      November 8, 2016 2:30 PM PST
    0
  • It does install Kevin, but for some reason (I'll check when I have time) you don't have a shortcut to the program being created. By running the "78+Community+Cataloger+-+Beta+2C.exe" file you are just installing the program yet again!

    Go to the "Program Files" folder on your harddrive - or Program Files (x86) if you have a 64 bit system - and you'll find a 78rpmCat folder. Inside that folder you'll find a Cat78.exe file. Create a shortcut to that and use that to run the program. This post was edited by wes williams at November 9, 2016 4:25 AM PST
      November 9, 2016 4:23 AM PST
    0
  • Thanks for replying so quickly.

    Unfortunately, it still doesn't seem to be installing "correctly". Since "78+Community+-+Beta+2C.exe" is suppose to be the Install Program, it makes sense that I get the Windows security warning every time I run it.

    The only location that I find a 78rpmCat folder is under my user name. In this case: "C:\User\Kevin Kittle\78rpmCat". At that location in the 78rpmCat directory, there is an "Audio" directory, an "Images" directory, and the db78.db78 file. There isn't a 78rpmCat folder in "Program Files" or "Program Files (x86)".  After a search, I cannot find a "Cat78.exe" file anywhere.

    I am concerned that by running "78+Community+-+Beta+2C.exe" every time that it will replace the "db78.db78" data file every time.
      November 9, 2016 10:25 AM PST
    0
  • [blockquote class='siteforum_icon_quote']Kevin Kittle said:
    I am concerned that by running "78+Community+-+Beta+2C.exe" every time that it will replace the "db78.db78" data file every time.[/blockquote]
    It doesn't replace your database when you re-install. That's so any existing database doesn't get overwritten when there is an update.

    I can't figure out how you can run the program itself if its not installed somewhere - the fact that you have the 78rpmCat folder with the database file and the two sub-folders in your user area shows that the install is working. Any chance you pointed the install directory to somewhere else, or you have it installed on another drive?

    Does the program itself run when you install it? Normally it doesn't during an install - it just adds a shortcut to the desktop that you double click to run it.
      November 9, 2016 3:18 PM PST
    0
  • When I run "78+Community+-+Beta+2C.exe", by double-clicking the file, the response is a pop-up window with the security warning, "Open File - Security Warning; The publisher could not be verified. Are you sure you want to run this software?; etc." The choice is: "Run" or "Cancel". I press "Run" and "The 78rpm Record Cataloger" opens in its own window ready to accept data entries at the "Catalogue" page with the cursor in the "Record Reference" block.

    So, yes, the program itself runs when I try to install it. There isn't an install sequence. There isn't an opportunity point to another directory or drive.

    After a data entry test, I confirmed that the db78.db78 file doe not get over-written when I launch "78+Community+-+Beta+2C.exe".

    It is an odd situation. I can live with it by creating my own shorcut and diabling the security warning, but I know that it isn't suppose to work that way. I'm not a programmer, but maybe the code line that is suppose to launch the installer got turned off somehow.
      November 10, 2016 1:34 PM PST
    0
  • The final result of this problem is beyond anything we at 78rpmCommunity can do to resolve it directly.  The install software uses a well known, mature, installer packager called NSIS to package and install the Cataloger software. The problem would seem to be related to NSIS, so I've made the .exe file (the program only) available to Kevin to download. Any reports of similar problems would be welcome.
      November 12, 2016 10:39 AM PST
    0
  • I am having the exact same problem as Kevin. I'm running Win 7 Pro 64-bit.

    I don't see any usual install options. Clicking on the 78+Community+Cataloger+-+Beta+2C.exe file brings the application right up, without anything to agree to or any other buttons to click.

    Jon Scaptura
      April 9, 2017 6:21 PM PDT
    0
  • FYI, I've downloaded the program today, and also don't see any install options.  Like Jon, running the downloaded file will run the application, not an installer.
      April 23, 2018 1:57 AM PDT
    0
  • Hi,

    I am having the same issue when installing under Windows 7 Pro 64 bit.  I did have a copy of the old 78rpm Record Cataloger Beta.2.0.exe software and that one installs correctly creating the appropriate sub directories and entry in the start menu.  The 2.0C does not create a folder under the programs folder and does not create an entry on the start menu but does create a folder under the user directory.  I wonder if you could post the 2.0C executable?  I would think that I could install the 2.0 version and then replace the executable in the programs folder.

    This could be an issue with the Windows 7 Pro 64 bit operating system and the installer.

    Thanks, Ron
      January 10, 2019 7:09 PM PST
    0